Launching the Application Server

From ADempiere
Revision as of 05:10, 30 December 2006 by Afalcone (Talk)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
This Wiki is read-only for reference purposes to avoid broken links.

Getting further HELP

  • Further requests for assistance please direct to the HELP Forum. This wiki provides only written and publishable support.
  • Further private, local, or commercial assistance can be sought at World-wide Directory where consultants all over register themselves. The fee charges are up to the respective consultants and under their own responsilibity or control.
  • Please adhere to our bazaar etiquette to enjoy better support from us.

Complete ADempiere Server Install

Before to start, you should have steps accomplished:

Start Application Server

You can now start the JBoss based ADempiere Application Server. To do it, go to console command and go to utils directory into your $ADEMPIERE_HOME. The run the script 'RUN_Server2 (.bat or .sh depending of your S.O.) Then you will see the RUN_Server2 output, such as:

IS RUN Server2.PNG

Please check that should be NOT errors there. You can take a look into the logs to verify this (they are located at $ADEMPIERE_HOME/jboss/server/adempiere/logs).

The most commons problems are with the ports, when some of them are used. In this case, you check the ports where you are receiving error. Typical conficts ports are:

  • HTTP: 80, 443, 8080, 8443
  • RMI : 1098, 1099

Any port conflict when starting the Application Server must be solved.